java - Совместимость JDK 11 и JRE 8


1

Будет ли приложение, написанное на JDK 11, работать у пользователя, у которого установлен JRE 8? Если нет, то как сделать так? (кроме как устанавливать JDK, который обычный пользователь вряд ли захочет ставить)

Источник
  •  84
  •  1
  • 31 янв 2019 2019-01-31 11:34:56

1 ответ

2

Если при компиляции приложения была указана целевая платформа версии 8 или ниже, то будет. Если выше, то не будет.