Android/Java Javadoc отсутствует после обновления Android SDK

После того как я недавно установил новый Android SDK, я больше не могу просматривать Javadoc при редактировании кода проекта. Я получаю это сообщение: Note: This element has no attached source and the Javadoc could not be found in the attached Javadoc.

Я получаю это сообщение для всех методов, переменных, классов и т.д.

Я установил документацию и все доступные мне с помощью диспетчера обновлений Android. Я также попытался выполнить чистую установку sdk android и eclipse, и вам не повезло работать с javadoc.

Я также попытался вручную установить javadoc через project properties -> javadoc location -> file:/C:/Program Files/Android/android-sdk-windows/docs/reference/ без везения

Какие предложения у вас есть, чтобы решить эту проблему?

5 ответов

Я понял, как решить эту проблему. Все, что мне нужно было сделать, это удалить папку .metadata в моей рабочей области и перезапустить eclipse. note: это очистит все ваши предпочтения, настройки и т.д. ваши проекты рабочей области должны будут быть добавлены снова.

также рассмотрим следующую ссылку, поскольку это очень полезно для большинства людей, рассматривающих это: http://hacksoflife.blogspot.com/2011/02/losing-javadocs-in-eclipse-solution.html


Удаление. metadata не является хорошим решением, потому что вы потеряете все свои настройки. Я немного задумался и смог понять это. Полная запись здесь:

http://hacksoflife.blogspot.com/2011/02/losing-javadocs-in-eclipse-solution.html


1) In eclipse, right click on your Android project and select Properties
2) On the menu on the left, select "Java Build Path"
3) On the right hand side, select the "tab" labelled "Libraries".
4) Here you should see the Android SDK that you're targeting. For example: "Android 2.2".
5) Click on the arrow to the left of the Android SDK to expand the sublevels.
6) Find "Android.jar" and click on the arrow to the left of that one as well to expand it.
7) You'll see a setting called "Javadoc location". Select that and then click on the "Edit" button.
8) At the top, RESELECT the path to your javadocs. This is usually "path_to_android_sdk/android-sdk-mac_86/docs/reference/". I say RESELECT because even if it right, you should browse and do it over anyway.
9) Click on "validate". You should be all set now!


Еще одно предложение: с моей установкой изменение пути не сработало! Проверка была в порядке, но после закрытия свойств проекта она переключилась на старый неправильный путь. (После установки Android SDK я переместил его в другое место, неправильный путь javadoc был в этом старом местоположении перед перемещением. Это, вероятно, вызвало мою проблему.)

Мое решение теперь состояло в следующем: открыв настройки Eclipse, перейдите на Android, и там измените путь местоположения SDK на "Обзор" на новое место. Я напечатал новое место, но после просмотра d:... изменился на D:... - и волшебным образом, после этого я теперь мог изменить путь javadoc в настройках проекта, и он помнит мои выбор. Даже создание новых проектов теперь работает так, как ожидалось, с правильного пути javadoc с самого начала.


Моя проблема заключалась в том, что я не мог видеть javadoc также для других библиотек, хотя проверка пути прошла нормально.

К сожалению, решение cjserio не помогло. Я не хотел принимать решение binnyb.

Согласно ответу от Jockel, я посмотрел местоположение Android SDK и увидел, что путь был "C:\Progra ~ 1\Android\android-sdk" вместо "C:\Program Files\Android\android-sdk".

Хотя это правильный путь, но после переезда я получил "C:\Program Files\Android\android-sdk" в качестве пути к местоположению и мог видеть все javadocs снова и после перезапуска Eclipse

UPD Но затем я получаю следующую проблему. Я больше не мог запускать симулятор, потому что плагин больше не мог понять путь. Эта проблема была вызвана пробелом в "Program Files".

Но я решение для этой проблемы также

Работаю отлично для меня

licensed under cc by-sa 3.0 with attribution.