Asp.net изменяет.net framework 4.0 до 3.5

У меня есть веб-приложение в asp.net 4.0, но я хочу изменить.net framework на 3.5.

Если я изменю его в свойствах и запустил веб-приложение, это даст мне ошибку:

Не удается загрузить файл или сборку AspNet.ScriptManager.jQuery или одну из его зависимостей. Эта сборка построена с использованием среды выполнения, более новой, чем текущая загруженная среда выполнения и не может быть загружена.

<span>Описание</span>: Необработанное исключение возникло во время выполнения текущего веб-запроса. Просмотрите трассировку стека для получения дополнительной информации об ошибке и ее возникновении в коде. Сведения об исключении: System.BadImageFormatException: Не удалось загрузить файл или сборку AspNet.ScriptManager.jQuery или одну из его зависимостей. Эта сборка построена с использованием среды выполнения, более новой, чем текущая загруженная среда выполнения и не может быть загружена.

Необработанное исключение было создано во время выполнения текущего веб-запроса. Исходя из следующей трассировки стека исключения, вы можете получить дополнительную информацию о происхождении и местоположении исключения.

я действительно не сейчас, что делать.

Спасибо!

1 ответ

Часть сообщения об исключении содержит ключ к проблеме.

Эта сборка построена с использованием среды выполнения, более новой, чем текущая загруженная среда выполнения и не может быть загружена.

AspNet.ScriptManager.jQuery нацелен на.NET 4 (или выше), и вы нацеливаете.NET 3.5. Таким образом, вам нужно найти версию AspNet.ScriptManager.jQuery, предназначенную для.NET 3.5, или целевое приложение на.NET 4.

Глядя на пакет Nuget для AspNet.ScriptManager.jQuery, он доступен только для.NET 4 и выше. Поэтому, если вы хотите использовать этот пакет, ваше приложение должно настроить таргетинг на.NET 4 или выше.

licensed under cc by-sa 3.0 with attribution.