Что может привести к тому, что iis не позволит просматривать каталог?

im пытается настроить и сущность frameWork, которая собирается использовать sql-server 2008 для разрастания базы данных с помощью первого кода... Так что я просто начинаю с создания 2 класса, которые содержат некоторые приличия для тестирования этого... ( с asp.net):

сделать класс Статьи:

public class Articles
{
 public int ID { get; set; }
 public string desc{ get; set; }
 public decimal price { get; set; }

 public Articles()
 {

 }
}

сделать класс Магазины:

public class Stores
{

 int ID { get; set; }
 String Name { get; set; }
 List<articles> Elements { get; set; }

 public Stores()
 {

 }
}
</articles>

Последующий класс Context:

public class dbSroreContext : DbContext
{

 public DbSet<stores> Stores { get; set; }
 public DbSet<articles> Articles { get; set; }

 public dbSroreContext()
 {

 }
</articles></stores>

}

ok, тогда я помещаю строку подключения в свой файл web.config:

<configuration>


 <configsections>

 <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->


 </configsections>
 <system.webserver>
 </system.webserver>
 <connectionstrings>
 <add connectionstring="Server.;" name="dbSroreContext" providername="System.Data.SqlClient">
 </add></connectionstrings>
 <system.web>

 <compilation debug="true" targetframework="4.5">
 <httpruntime targetframework="4.5">
 </httpruntime></compilation></system.web>

</configuration>

пока я пытаюсь включить мой браузер каталогов в моем IIS, но никакого результата...

Error : The Web server is configured to not list the contents of this directory.

Most likely causes:
A default document is not configured for the requested URL, and directory browsing is not enabled on the server.
1 ответ

ОК, наконец, я получил лучшее решение, которое я хочу! У меня больше одного сервера на моем компьютере... и это было беспорядок с сервером, позволяющим просматривать файлы каталога! Так что лучшее, что я могу сделать, это включить его с уровня веб-сайта:

<system.webserver>
 <directorybrowse enabled="true">
 </directorybrowse></system.webserver>

добавьте это в файл web.config, и все должно быть хорошо! Надеюсь, это может помочь другим: D ty для помощи! : D

licensed under cc by-sa 3.0 with attribution.