Как использовать другую версию Npm и Cordova

Мы загрузили и установили другой экземпляр Npm вне Visual Studio на нашей машине разработки и установили путь к системе для использования этой версии; используя этот Npm, мы загрузили последнюю версию Кордовы (3.5.0).

По-видимому, похоже, что Visual Studio 2013 использует эту новую установку Npm и версию Cordova при создании; используя эту конфигурацию, мы можем правильно строить и развертывать WP8, Android и iOS. Также плагины (активированные из config.xml в VS) загружаются и устанавливаются на новом пути Кордовы.

Посмотрев на журнал сборки, я заметил, что в iOS-сборке сообщается, что используется версия 3.4.0 Кордовы.

Поддерживается ли такая конфигурация? Каков правильный способ использования другой версии Кордовы?

1 ответ

Если вы обновите гибридные приложения Multi-Device на CTP2, Visual Studio теперь использует Cordova 3.5.0 вместо 3.4.1. Вы также должны обновить свой экземпляр vs-mda-remote на вашем Mac, чтобы оставаться в синхронизации для iOS.

В настоящее время нет поддерживаемого способа выбора версии Кордовы, хотя она и находится в дорожной карте.

licensed under cc by-sa 3.0 with attribution.