Конфликт версий при добавлении поддержки Google Cloud Storage к существующему Webapp

У меня есть приложение webapp и java, которое подключается к Bigquery. Я пытаюсь добавить поддержку Cloud Storage с помощью примера StorageSample.

Но при запуске этого кода:

Storage storage = new Storage.Builder(HTTP_TRANSPORT, JSON_FACTORY, credential).setApplicationName(
 BigqueryUtils.PROJECT_ID).build();

Я получаю следующую ошибку:

You are currently running with version 1.17.0-rc of google-api-client. You need version 1.14.1-beta of google-api-client to run version 1.14.1-beta of the Cloud Storage API library.
1 ответ

Быстрое решение: Привет Febian: Почему вы не просто захватить новую версию клиента экспромты из здесь? Лучший способ управлять библиотеками: мне удавалось использовать Maven для управления зависимостями для Google Java Client Libs. Проверьте ссылку "Добавить библиотеку в свой проект" на той же странице.

licensed under cc by-sa 3.0 with attribution.