Насколько безопасно обновлять версию Java для Cloudera?

У меня кластер cloudera, работающий под Cloudera Standard 4.7.3 и CDH 4.5 с Java 1.6.

в соответствии с Ducumetation Cloudera эти версии поддерживают java 1.7.

Я хочу знать, безопасно ли это обновление или имеются ли с ним потенциальные проблемы?

2 ответа

Мы обновили наш кластер до java 1.7 и не испытывали никаких проблем ни с заданиями M/R, ни с работами Hive


Безопасно использовать любую поддерживаемую версию Java с CDH. Вы можете безопасно использовать его с версиями Java 7, которые, как видите, были протестированы. Конечно, вам нужно запустить ту же версию Java через ваш кластер.

Неподдерживаемые версии, вероятно, тоже работают отлично, но не гарантируются.

licensed under cc by-sa 3.0 with attribution.