Не удалось использовать cocoapods после обновления

У меня есть обновления Ruby, Gems и Cocoapods на моем Mac OSX 10.9.5, после обновления я не могу выполнить команду

pod install

Я получаю следующую ошибку с терминала

/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.34.2/lib/cocoapods/user_interface/error_report.rb:13:in `report': incompatible character encodings: UTF-8 and ASCII-8BIT (Encoding::CompatibilityError)
 from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.34.2/lib/cocoapods/command.rb:61:in `report_error'
 from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:300:in `handle_exception'
 from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:274:in `rescue in run'
 from /Library/Ruby/Gems/2.0.0/gems/claide-0.7.0/lib/claide/command.rb:264:in `run'
 from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.34.2/lib/cocoapods/command.rb:48:in `run'
 from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.34.2/bin/pod:33:in `<top (required)="">'
 from /usr/bin/pod:23:in `load'
 from /usr/bin/pod:23:in `</top><main><code>'
</code>
<p>Я создал подфайл с содержимым ниже</p>
<pre class="prettyprint linenums">platform :ios, ‘7.1’
pod 'AFNetworking', '~> 1.3.3’

Cocoapods отлично работали до обновления. любая помощь очень ценится.

2 ответа

Этот символ "'" несовместим с кокоаподами в первой строке. Вы должны использовать это вместо "". Итак, ваш podfile должен выглядеть следующим образом:

platform :ios, '7.1'
pod 'AFNetworking', '~> 2.4'


Проблема заключалась в использовании неправильных котировок в версии iOS. Убедитесь, что все ваши кавычки "а не" или.

licensed under cc by-sa 3.0 with attribution.