Ошибка: не удалось найти или загрузить основной класс com.google.gwt.dev.Compiler

Какие шаги воспроизведут проблему? и как я могу решить эту проблему

  1. В Eclipse Indigo щелкните правой кнопкой мыши project name --> google --> GWT Compile --> Compile

Я получил ошибку, которая говорит

Не удалось скомпилировать GWT

В окне консоли Eclipse появилось сообщение об ошибке

Ошибка: не удалось найти или загрузить основной класс com.google.gwt.dev.Compiler

Я использую окна 7, eclipse juno 4.2 и GWT sdk 2.5.1

Во время установки Gwt я отключил все параметры SDK для приложений. А также сконфигурируйте путь сборки для файлов jar для проектов, которые у меня есть. но все же эта проблема наступает.

Спасибо за ответ. хорошо я пробовал это раньше, но ничего не произошло. Затем я удаляю все. И перейдите к HELP---> Установить новый Software---> в текстовой области, я использовал эту ссылку Сайт Google Update для Eclipse 4.2 - http://dl.google.com/eclipse/plugin/4.2 тогда всякий раз, когда я проверял плагин Google для eclipse (обязательно) и нажимал дальше, он показывает Не удается завершить установку, так как не удалось найти один или несколько требуемых элементов.Установленное программное обеспечение: плагин Google для Eclipse 4.2 3.2.4.v201306061638-rel-r42 (com.google.gdt.eclipse.suite.e42.feature.feature.group 3.2.4.v201306061638-rel-r42) Отсутствует требование: Google Плагин для Eclipse 4.2 3.2.4.v201306061638-rel-r42 (com.google.gdt.eclipse.suite.e42.feature.feature.group 3.2.4.v201306061638-rel-r42) требует 'org.objectweb.asm 0.0. 0 ', но он не может быть найден я не понимал, что и где проблема.

2 ответа

Я бы дважды проверил вашу установку GWT. Щелкните правой кнопкой мыши по проекту в eclipse и выберите "Свойства". Затем в разделе "Google" выберите "Веб-инструмент". На панели справа должен быть вариант "Использовать Google Web Toolkit". Убедитесь, что этот флажок установлен. Также нажмите "Настроить SDK" и убедитесь, что выбранные SDK действительно указывают на правильное расположение файла. Наконец, убедитесь, что ваши точки входа правильно добавлены в панель "Модули точки входа".


Я столкнулся с подобной проблемой. Я изменил прокси-сервер моего затмения на руководство и установил параметры прокси-сервера для HTTP, HTTP и порта как 8080. Это позволило eclipse подключиться к сети и загрузить необходимые плагины. Попробуйте это и сообщите нам, если это поможет.

licensed under cc by-sa 3.0 with attribution.