Polarssl-dev - Ubuntu 14.04

Я хотел бы установить polarssl-dev для Ubuntu 14.04 из своих репозиториев. Я читал, что это было доступно во вселенной на https://launchpad.net/ubuntu/+source/polarssl, но я включил юниверс, включая src, и его там не было. Как я могу это сделать?

# apt-get install polarssl-dev Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package polarssl-dev

# grep univer/etc/apt/sources.list deb http://be.archive.ubuntu.com/ubuntu/trusty main restricted universe multiverse deb-src http://be.archive.ubuntu.com/ubuntu/trusty main restricted universe multiverse deb http://be.archive.ubuntu.com/ubuntu/trusty-security main restricted universe multiverse deb http://be.archive.ubuntu.com/ubuntu/trusty-updates main restricted universe multiverse deb http://be.archive.ubuntu.com/ubuntu/trusty-proposed main restricted universe multiverse deb http://be.archive.ubuntu.com/ubuntu/trusty-backports main restricted universe multiverse deb-src http://be.archive.ubuntu.com/ubuntu/trusty-security main restricted universe multiverse deb-src http://be.archive.ubuntu.com/ubuntu/trusty-updates main restricted universe multiverse deb-src http://be.archive.ubuntu.com/ubuntu/trusty-proposed main restricted universe multiverse deb-src http://be.archive.ubuntu.com/ubuntu/trusty-backports main restricted universe multiverse

Если кто-то не возражает сказать, как я поступил не так, я был бы очень благодарен.

С уважением, Соф.

1 ответ

Имена пакетов для PolarSSL фактически начинаются с lib. Это должно сработать для вас:

$ sudo apt-get install libpolarssl-dev
Reading package lists... Done
Building dependency tree 
Reading state information... Done
The following extra packages will be installed:
 libpolarssl5
The following NEW packages will be installed:
 libpolarssl-dev libpolarssl5
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 459 kB of archives.
After this operation, 1,962 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty/universe libpolarssl5 amd64 1.3.4-1 [186 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/universe libpolarssl-dev amd64 1.3.4-1 [274 kB]
Fetched 459 kB in 6s (71.3 kB/s) 
Selecting previously unselected package libpolarssl5.
(Reading database ... 61244 files and directories currently installed.)
Preparing to unpack .../libpolarssl5_1.3.4-1_amd64.deb ...
Unpacking libpolarssl5 (1.3.4-1) ...
Selecting previously unselected package libpolarssl-dev.
Preparing to unpack .../libpolarssl-dev_1.3.4-1_amd64.deb ...
Unpacking libpolarssl-dev (1.3.4-1) ...
Setting up libpolarssl5 (1.3.4-1) ...
Setting up libpolarssl-dev (1.3.4-1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

licensed under cc by-sa 3.0 with attribution.