Проблемы с установкой Ltib

Я пытаюсь установить ltib, для установки некоторых пакетов, которые мне нужны. Я дошел до места установки, где я

./ltib

и это дает мне эту ошибку в host_config.log

Build path taken because:no prebuilt rpm
Can't get: rpm-4.0.4.tar.gz at ./ltib line 851
Died at ./ltib line 2557
traceback:
 main::check_rpm_setup:2557
 main::host_checks:1541
 main:562

.... 
and then it says : 
 These packages failed to build:
 rpm-fs
Build failed

У меня есть rpm на этой установке debian linux. Я даже скачал rpm-4.0.4.tar.gz и поместил его в тот же каталог, что и. /ltib

Кто-нибудь сталкивался с этой ошибкой раньше? Другой вопрос: мне нужно подключение к Интернету для установки ltib? (Я загрузил tar с веб-сайта)

1 ответ

эта проблема была решена, вам нужно изменить строку 12 в файле rpm.spec, который находится /dist/lfs-5.1/rpm.

изменение

Source : %{name}-%{version}.tar.gz"

чтобы:

Source : http://rpm.org/releases/historical/rpm-4.0.x/rpm-4.0.4.tar.gz

Я думаю, что некоторые файлы отсутствуют на сервере bithrine.org. Вы можете применить одно и то же решение для других отсутствующих файлов.

licensed under cc by-sa 3.0 with attribution.