Python3.2.2 установить ошибку easy_install

Я хочу изучить python, поэтому я получаю python3.2.2 и устанавливаю его на ubuntu10. Как мы знаем, Ubuntu был предустановлен python2.6. Так что удалите старую ссылку и создайте новую ссылку на python3.2.2, все в порядке.

Теперь я хочу установить easy_install, и я выполнил шаги на веб-сайте.

sudo wget http://peak.telecommunity.com/dist/ez_setup.py 
python ez_setup.py

и возникает ошибка:

xx@ubuntu:/usr/local/lib/python2.6/dist-packages$ python ez_setup.py 
File "ez_setup.py", line 106
except pkg_resources.VersionConflict, e:
 ^
SyntaxError: invalid syntax

показано сообщение: я использую python2.6!!! Что мне нравится, мне нравится python3.2.2, поэтому я проверил текущую версию pyton.

xx@ubuntu:/usr/local/lib/python2.6/dist-packages$ python
Python 3.2.2 (default, Mar 9 2012, 07:38:22) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.

он показывает, что теперь я использую python 3.2.2. Итак, как я могу внести изменения в установку ez_setup.py?

спасибо.

2 ответа

Кажется, это проблема с версией easy_install. В Serverfault есть аналогичный поток. Проверьте это:

https://serverfault.com/questions/73741/easy-installing-under-different-python-version

Это аналогичный случай, но нужно установить для более старой версии.


ez_setup.py не работает с python3.x Вернитесь назад к python2.x, и он должен начать работать. (Мой опыт работы с 64-битной установкой)

licensed under cc by-sa 3.0 with attribution.