Ssl на локальном dev-сервере

Я запускаю ubuntu в качестве тестового сервера на своем ноутбуке. Я пытаюсь настроить некоторые из тестовых сайтов с самоподписанными сертификатами ssl. Я думаю, что все правильно, за исключением, возможно, файлов apache 2 conf.

При создании cerificates я дал общее название как *.hr4.mdev. "mdev" - это то, что я произвольно назвал своей локальной средой dev.

Поэтому я изменил свой существующий файл conf для прослушивания на 443 вместо 80 (строка 1), и я добавил строки 6, 7 и 8.

<virtualhost *:443="">
 ServerAdmin [removed_email]
 ServerName marino.hr4.mdev
 ServerAlias *.marino.hr4.mdev
 DocumentRoot /var/www/marino.hr4/htdocs
 SSLEngine on
 SSLCertificateFile /etc/apache2/ssl/apache.crt
 SSLCertificateKeyFile /etc/apache2/ssl/apache.key
 <directory var="" www="" marino.hr4="" htdocs="">
 php_value include_path /var/www/marino.hr4/htdocs
 Options Indexes FollowSymLinks MultiViews
 AllowOverride All
 Order allow,deny
 allow from all
 </directory>

 ErrorLog /var/www/marino.hr4/logs/error.log
 # Possible values include: debug, info, notice, warn, error, crit, alert, emerg.
 LogLevel debug

 CustomLog /var/www/marino.hr4/logs/access.log combined
</virtualhost>

Теперь, когда я иду на сайт (https://marino.hr4.mdev), мне сообщают, что "это работает!" Что обнадеживает на определенном уровне, но это не тот контент, который я ожидал увидеть.

Имея ссылку на ссылку тремора, мой файл conf теперь выглядит следующим образом:

<virtualhost 192.168.73.128:443="">
 SSLEngine on
 SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP

 SSLCertificateFile /etc/apache2/ssl/apache.crt
 SSLCertificateKeyFile /etc/apache2/ssl/apache.key

 ServerAdmin [removed_email]
 ServerName marino.hr4.mdev
 ServerAlias *.marino.hr4.mdev
 DocumentRoot /var/www/marino.hr4/htdocs

 <directory var="" www="" marino.hr4="" htdocs="">
 php_value include_path /var/www/marino.hr4/htdocs
 Options Indexes FollowSymLinks MultiViews
 AllowOverride All
 Order allow,deny
 allow from all
 </directory>

 ErrorLog /var/www/marino.hr4/logs/error.log
 # Possible values include: debug, info, notice, warn, error, crit, alert, emerg.
 LogLevel debug

 CustomLog /var/www/marino.hr4/logs/access.log combined
</virtualhost>

после перезапуска Apache меня попросят добавить исключение безопасности, и это нормально, но меня затем выталкивают на другой сайт, который я установил на своей машине.

2 ответа

Поэтому в конце я изменил файл ports.conf и добавил 443 в директиву Listen, поэтому теперь он читает:

Listen 80 443
<ifmodule ssl_module="">
 Listen 443
</ifmodule>
<ifmodule mod_gnutls.c="">
 listen 443
</ifmodule>

Я также изменил первую строку моего файла conf из

вернуться к

Особая благодарность тремолу за то, что он указал мне в правильном направлении.


Добавьте директиву NameVirtualHost, что-то вроде этого, возможно?

NameVirtualHost *:443
Listen 443

Ваш сервер Apache, очевидно, обслуживает сервер по умолчанию "Он работает" вместо вашего веб-сайта.

Вот некоторая вспомогательная информация от apache: http://wiki.apache.org/httpd/NameBasedSSLVHosts

Редактировать:

Потенциально переместите ваш виртуальный хост на первый ссылочный vhost в файле conf, по умолчанию выбран по заказу.

licensed under cc by-sa 3.0 with attribution.