Установите PECL на Mac OS X 10.6

Есть ли способ установить PHP: s PECL-обработчик в Mac OS X 10.6, который будет использоваться вместе с PHP?

2 ответа

Лучше поздно, чем никогда, но если вы похожи на меня и установили PHP прямо из php.net(вместо использования чего-то вроде Homebrew или Port, вы можете просто следовать следующей ссылке, чтобы установить Pear и PECL:

http://akrabat.com/php/setting-up-php-mysql-on-os-x-10-7-lion/

Нам нужен PEAR! По какой-то причине он не настроен на Lion, но файл установки phar находится здесь, поэтому нам просто нужно запустить его.

<pre class="prettyprint linenums">cd /usr/lib/php sudo php install-pear-nozlib.phar Edit: /etc/php.ini and find the line: ; include_path = ".:/php/includes" and change it to: include_path = ".:/usr/lib/php/pear" sudo pear channel-update pear.php.net sudo pecl channel-update pecl.php.net sudo pear upgrade-all </pre>

Это сработало для меня.


Попробуйте установить его через:

bash <(curl -s http://php-osx.liip.ch/install.sh)

Или установите вручную:

curl -s -o /tmp/packager.tgz http://php-osx.liip.ch/packager/packager.tgz
sudo tar -C /usr/local -xzf /tmp/packager.tgz

Затем установите упаковщик:

sudo /usr/local/packager/packager.py install 5.4-frontenddev

в противном случае обновите его с помощью:

sudo /usr/local/packager/packager.py install tools-frontenddev # Ignore

licensed under cc by-sa 3.0 with attribution.