Возможно ли получить проекты Windows Azure SDK 1.7 для запуска в эмуляторе 2.3?

Установленный Windows Azure SDK 2.3 на моем компьютере-разработчике, а теперь более старое решение VSQ 2010 Azure 1.7 SDK (июнь 2012 г.) не запускается со следующей ошибкой:

Средства Windows Azure: ошибка: установленный эмулятор Windows Azure не поддерживает исполняемые файлы роли. Установите последний эмулятор Windows Azure и повторите попытку. Средства Windows Azure: в системе отсутствует необходимое условие для выполнения службы. См. Примечания к выпуску.

Можно ли запустить 1,7 проектов с использованием эмулятора 2.3, или мне нужно удалить новый эмулятор и переустановить старый? Модернизация проекта в настоящее время не является вариантом.

1 ответ

SDK 1.8 представил бок о бок возможности для SDK и эмулятора, так что вы могли одновременно установить оба SDK. SDK 1.7 не имел такой же совместимости, поэтому вы не сможете запустить проект SDK 1.7 на компьютере с установленным SDK 2.3.

licensed under cc by-sa 3.0 with attribution.