Вопросы

Использованные поисковые фильтры:

41329 вопросов (0.2785)

Сколько я ни искал, всё как-то уж больно сложно и избыточно функционально... А я хотел максимальной простоты — работать с таблицей как с двумерным массивом строк. Ответ к которому я пришел - внизу :)
Мне нужно считывать каждую ячейку с данными построчно из файла excel и заполнять этими строками коллекцию. То есть, одна строка excel это один элемент коллекции, вторая строка это второй элемент коллекции. Проблема в том, что не расставляются запятые между ячейками. Не могу понять в чем проблема....
C# работа с Excel работаю в консольных приложениях. у меня стоит виндовс 10 и VS последняя актуальная версия. кое-как я методом тыка и вдумчивого гугления разобрался с элементарными задачами: прочитать данные в такой-то ячейке, записать данные в такую-то ячеку, и создать новую книгу. испол...

алексей

Как можно записать данные в документ Microsoft Excel?
Не завися при этом от версии Excel. Пытался пользоваться одной библиотекой , но файл не открывается, пишет не валидный. Пробовал вот
В программе на C# работаю с книгой Excel следующим образом. После выполнения этого кода процесс EXCEL.EXE продолжает висеть в диспетчере задач, но завершается после закрытия моей программы. Если убрать последние 3 строчки, то процесс висит в диспетчере и не завершается после закрытия моей...
Такой код должен искать номера строк из столбца J, сравнивая со значениями столбца А и заполнять столбец К. Но при использовании получаю ошибку: Что, насколько я понял, говорит о неверном диапазоне. Но уже несколько раз перепроверил, вроде всё верн...
Подскажите, пожалуйста, как составить формулу для выполнения условия: если значение ячейки меньше 90, то результат равен А, если больше 90, но меньше 180, то - В, если больше 180, но меньше 270, то С, иначе - D. Пробовал формулу =ЕСЛИ(А1270;"D")) - но это тольк...

alexnik

Здравствуйте! Я не имею большого опыта написания в VBScript. Сейчас пишу макрос для специализированной программки, в процедуре несколько циклов. Вначале я оглашаю размер формируемого массива, и в процессе расчётов он заполняется. Как вывести его в конце (после отработки макроса) в Ексель? ...
Как сделать проверку excel файла на наличие всех меток(по столбцу label): То есть, например, если нет 14ой метки, программа добавляла ее в столбец со значением 9999: Есть код, который выгружает данные метки, теперь нужна проверка по файлу result: Необходимо чтобы п...

Рамиль Фазлиахметов

Здравствуйте, занимаюсь в одном рабочем приложении экспортом в Excel, возникла необходимость добавления столбца, в котором указаны номера строк. Сейчас это делаю через цикл: Но работает на большом объеме данных весьма медленно, есть ли идеи как это сделать проще?

Василий Ермилов

Добрый день, есть вот такая табличка Мне нужно находить последнюю заполненную строчку столбца "А", а потом записать в столбцы "a,b,c,d.." следующей строки информацию. Этот код записывает в последнюю заполненную строку "А" Но если использовать этот метод, то столбец "B" запи...
В Сложное условие в Excel есть формула =ВПР(A2;{0;1:90;2:180;3:270;4};2;1). Но она у меня не работает и я не ...

Евгений Анатольевич

Нужно реализовать метод записи в Excel файл. Пробую: Затем: При указании такого пути как "log.xlsx" файл не создается в текущей директории, а где - непонятно. Почему? Если указать абсолютный путь, то все ОК. И если файл перезаписывается (повторное вызывание метода), то выскакивает...
Дано: Есть БД в приложении под андроид. Для работы с ней пользуется OrmLite. Задача: Надо её, базы, содержимое посмотреть в виде таблиц Excel для целей дебага. Что сделано:
Вот два скрина: http://prntscr.com/bin23c - это сама формула, прикреплю еще код сюда. Вот страница, где должна работать формула: http://prntscr.com/bin2ti

StokOne

Здравствуйте уважаемые программисты. Передо мной стоит задача автоматизации отчетности в Excel. На первый взгляд около 200 отчетов. Смотрел в интернете классы для выгрузки, но с помощью них очень долго и "напряжно" делать. Есть ли какая-нибудь универсальная система, может класс, поддержива...

Артем Дмитриев

Есть массив $arr с текстовыми объектами по типу: "target:value" Пытаюсь его перебрать таким способом, и записать значения в файл: Но проблема в том что мне нужно чтобы target был во первой ячейке таблицы, а value во второй. Сейчас...
Доброго дня/вечера. Хотел бы создать xls (excel) файл, с помощью PHP, в который бы записал данные из mysql, чтобы там были: Т.е. я так понимаю, файл создастся, и нужно будет как-то его сохранить. Не открывать, не пытаться его открыть, просто создать с нужными данными и все. ...
Здравствуйте, подскажите как из Excel импортировать данные в таблицу DataGrid WPF. Заранее благодарен.